Why does xdebug crash apache on every XAMPP install I've tried?

Question!

I've installed the Windows XAMPP package on three separate computers, 2 running Windows Vista 32 bit ( 1 Ultimate / 1 Home Premium ) and 1 running Windows Vista 64 Home Premium.

After enabling xdebug in php.ini and restarting apache, viewing the default XAMPP localhost index causes apache to crash in the same way every time, reporting 'php_xdebug.dll' as the Fault Module Name.

Here's the full report from the Windows Crash Reporter thing:

Problem signature:
Problem Event Name: APPCRASH
Application Name:   apache.exe
Application Version:    2.2.9.0
Application Timestamp:  4853f994
Fault Module Name:  php_xdebug.dll
Fault Module Version:   2.0.3.0
Fault Module Timestamp: 47fcd9b9
Exception Code: c0000005
Exception Offset:   00008493
OS Version: 6.0.6001.2.1.0.768.3
Locale ID:  1033
Additional Information 1:   a34a
Additional Information 2:   c9c5f4fd744690d388ab9d5b3eb051a7
Additional Information 3:   cb2e
Additional Information 4:   650bb5690556a17e911375b94d3e16f0

I've tried Googling this issue but haven't found any resolution, only reports of similar errors.

EDIT: I enabled the extension line for php_xdebug.dll and that seems to have stopped the crashing so far.



Answers

I was looking in internet for this issue and tried many solutions and none of them worked. I tried this configuration, just a last test and worked for me, in Eclipse change under Windows/Preferences/PHP/Debug and select Xdebug as PHP debugger.

By : ferweb


This video can help you solving your question :)
By: admin