This Question have no Text answers yet!

Android Exception writing to parcel error, Permission Denial: get/set setting for user

Question!

I have an Android app which I'm just trying to finish off for publication. I've been running it for a few days on Google Play as a Beta App and it has been fine. I uploaded a new Beta version today and it is behaving very strangely with buttons not working sometimes, crashes and just seemingly random errors all over the place. The app is not working at all. When I load it onto my phone from Android Studio it works. But when I send the signed version to Google Play and load it onto my phone it doesn't. It seems to be getting this error nearly all the time:

 E/DatabaseUtils: Writing exception to parcel
 java.lang.SecurityException: Permission Denial: get/set setting for user asks to run as user -2 but is calling from user 0; this requires android.permission.INTERACT_ACROSS_USERS_FULL
 at com.android.server.am.ActivityManagerService.handleIncomingUser(ActivityManagerService.java:13140)
 at android.app.ActivityManager.handleIncomingUser(ActivityManager.java:2038)
 at com.android.providers.settings.SettingsProvider.callFromPackage(SettingsProvider.java:607)
 at android.content.ContentProvider$Transport.call(ContentProvider.java:279)
 at android.content.ContentProviderNative.onTransact(ContentProviderNative.java:273)
 at android.os.Binder.execTransact(Binder.java:388)
 at dalvik.system.NativeStart.run(Native Method)

This seems to have something to do with SQLite, which my app uses a lot, but I really don't know what code to post because I don't know exactly where the error is coming from. Sorry about the lack of information, I don't know where to start with this. I have found other posts about the same error but they all seem to say not to add the

android.permission.INTERACT_ACROSS_USERS_FULL

permission to the manifest, but I don't have that in my manifeset and, as far as I am aware I'm not doing anything to interact across users.

All this seems to have coincided with some Android Studio updates I did this morning. I couldn't say what they were, I just accepted them and watched them install, could this be a possible issue?

Again, sorry for the rambling and a lack of information. Any help would be greatly appreciated!

Edit:

I have tried everything I can find in other questions to fix this and none of the solutions have worked. I have twice done a Clean of the project and resent the .apk to Google Play, but the errors are still happening. I tried using a new key to sign the project but Google Play won't let me upload it with a different key. I don't know where to go from here.

I get the feeling that this has all stemmed from the Android Studio Upgrade I did yesterday, it seems to have somehow corrupted my project, but I don't know anything about the file structure and I don't know where to look.

As an aside, clicking "show in folder" when my .apk file has been compiled seems to have told Windows 10 to permanently open a new window in explorer every time I click on a folder, which is very annoying. This is probably unrelated but this version of Android Studio does seem to be doing strange things. It is also highlighting an error in my code where I have:

calendar.get(Calendar.MONTH) == Calendar.SEPTEMBER

The error says:

Must be one of: Calendar.Sunday, Calendar.Mondy, Calendar.Tuesday, Calendar.Wednesday, Calendar.Thursday, Calendar.Friday, Calendar.Saturday

All of these things have happened since I upgraded Android Studio yesterday. If anyone can help I would be very grateful. Thank you for your time.

By : kwibbler



How to install new Android Studio extensions to IntelliJ IDEA

Will you recommend beginners to use Android Studio? [closed]

I can't install/launch Android Studio for Windows 7 64 bit [duplicate]

Android Studio / Intellij new project wizard

Android Studio - SDK is out of date or is missing templates

Does Android Studio support Maven?

Android Studio - Issue with Android SDK on Windows 7

Android Studio: Use AndroidAnnotations

Problems importing project into Android Studio regarding ActionBarSherlock

Can't start Android studio

Can't create new project in Android Studio on Mac OS [closed]

Android studio isn't opening on Windows

Video about Android Exception writing to parcel error, Permission Denial: get/set setting for user