I can't export a path in illustrator

Question!

I want to export a path from illustrator to svg, to display it on a browser and modify it. It is a simple wave, the path is not close. But when I do it I don't have a path tag but a style tag.

<?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<svg version="1.1" id="Calque_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="153.9px" height="39.7px" viewBox="0 0 153.9 39.7" style="enable-background:new 0 0 153.9 39.7;" xml:space="preserve">
<style type="text/css">
	.st0{fill:#FFFFFF;}
	.st1{fill:#1D1D1B;}
	.st2{fill:#FF004B;}
	.st3{fill:#CABA9F;}
	.st4{fill:#E20613;}
	.st5{fill:none;stroke:#020000;stroke-width:11;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:10;}
	.st6{enable-background:new    ;}
	.st7{clip-path:url(#XMLID_1030_);enable-background:new    ;}
	.st8{fill:#006591;}
	.st9{fill:#006895;}
	.st10{fill:#006B9A;}
	.st11{fill:#006F9E;}
	.st12{fill:#0072A3;}
	.st13{fill:#00628C;}
	.st14{fill:#005F88;}
	.st15{fill:#005C83;}
	.st16{fill:#00587F;}
	.st17{fill:#00557A;}
	.st18{fill:#005276;}
	.st19{fill:#0082BA;}
	.st20{clip-path:url(#XMLID_1031_);enable-background:new    ;}
	.st21{clip-path:url(#XMLID_1032_);enable-background:new    ;}
	.st22{fill:#004F71;}
	.st23{clip-path:url(#XMLID_1033_);enable-background:new    ;}
	.st24{clip-path:url(#XMLID_1034_);enable-background:new    ;}
	.st25{clip-path:url(#XMLID_1035_);enable-background:new    ;}
	.st26{clip-path:url(#XMLID_1036_);enable-background:new    ;}
	.st27{clip-path:url(#XMLID_1037_);enable-background:new    ;}
	.st28{fill:#FF0000;}
	.st29{fill:#662482;}
	.st30{fill:#93C01F;}
	.st31{fill:#009EE2;}
	.st32{fill:#F29100;}
	.st33{fill:#E61B72;}
	.st34{fill:#925F36;}
	.st35{fill:#E5332A;}
	.st36{fill:#E5007E;}
	.st37{fill:#35A8E0;}
	.st38{fill:#0000FF;}
	.st39{fill:none;stroke:#009EE2;stroke-width:8;stroke-miterlimit:10;}
	.st40{fill:none;stroke:#38FF70;stroke-width:8;stroke-miterlimit:10;}
	.st41{fill:none;stroke:url(#XMLID_1038_);stroke-width:8;stroke-miterlimit:10;}
	.st42{fill:none;stroke:url(#XMLID_1039_);stroke-width:8;stroke-miterlimit:10;}
	.st43{fill:none;stroke:url(#XMLID_1040_);stroke-width:8;stroke-miterlimit:10;}
	.st44{fill:none;stroke:#0000FF;stroke-width:8;stroke-miterlimit:10;}
	.st45{fill:none;stroke:url(#XMLID_1041_);stroke-width:8;stroke-miterlimit:10;}
	.st46{fill:none;stroke:url(#XMLID_1042_);stroke-width:8;stroke-miterlimit:10;}
	.st47{fill:none;stroke:url(#XMLID_1043_);stroke-width:8;stroke-miterlimit:10;}
	.st48{fill:none;stroke:url(#XMLID_1044_);stroke-width:8;stroke-miterlimit:10;}
	.st49{fill:url(#XMLID_1045_);}
	.st50{fill:none;stroke:#3100FF;stroke-miterlimit:10;}
</style>
</svg>

What I want is something like that :

<path d="M 100,180 L 140,0 L 180,180 L 220,0 L 260,180 L 300,0 L 330,180" style="fill:none; stroke:black"/>

This is what I usually have and that's why I don't understand why it is not working on that path

I follow these export settings : http://creativedroplets.com/export-svg-for-the-web-with-illustrator-cc/

Thanks



Answers

When the problem occurs again, save it through export. Not save as.

With these options -

svg export options

You will have a path id instead of style.

Or just dont do any export, just copy and paste selected layers right into your html file.

By : Phillip


What if you try to put this Annotation (see below) for the property that is not being populated:

[SitecoreField(FieldName = "MenuHeaderItem", FieldType = SitecoreFieldType.Droplist)]


I'd do it with zip and list comprehension.

>>> a = [2, 4, 1, 1, 6, 1, 1, 3, 5, 1]
>>> b = ["A", "B", "C", "D", "E", "F", "G", "H", "I", "J"]
>>> c = [x[0] for x in zip(b, a) if x[1] == 1]
>>> c
['C', 'D', 'F', 'G', 'J']
>>>


This video can help you solving your question :)
By: admin