library not found for -lsqlite3

Question!

Hello friends I'm new in iOS. I'm creating an app using sqlite. the app is running perfectly in simulator but not working in iPhone device. I search a lot but not getting the right solution. I got a link but it also not worked for me.

enter image description here

I downloaded some demo app of sqlite, but all apps showing same error. I'm not understanding what happened. PLZ help me I stuck with this issue.



Answers

The problem is my Xcode. I deleted my sqlite library by mistake that's it is not showing my sqlite library path. I uninstalled and installed new Xcode, and my issue resolved.



see the libsqlite3.o.tbd is shows on red color , just delete and add again and finally clean and run once .the visibility shows as black not red, see the attached image

enter image description here

updated answer

enter image description here

finally do clean and run



Open xCode click top project blue icon. Click Target-> build Phases -> Link Binary With Libraries -> add Other -> open Folder -> click Windows Shift G ->Enter /usr/lib then select library and add to your Project

try it.



This video can help you solving your question :)
By: admin