User does not have access to the AnalysisServices database

By : Webking
Source: Stackoverflow.com
Question!

We have a analysis services olap cube (SSAS 2008) deployed at a test server (MS Serve 2008) in our domain, you can browse the olap cube via ssms without problem. No problems with olap cube itself so far. The user account is admin on the analysis services server.

We also have reporting services (SSRS 2008) installed at the same test server and have a datasource inside the reporting services report that fetch data from the analysis service olap cube. We have set up windows integrated authentication setting but the user trying to connect trough reporting services report to the olap cube get access denied.

An error has occurred during report processing. (rsProcessingAborted)
Query execution failed for dataset 'DsMillCd'. (rsErrorExecutingCommand)
Either the user, KORSNET\TFMAN, does not have access to the AnalysisServices database, or the database does not exist. 

If i try out the same olap cube and report trough business intelligence studio local its working, so it must be some setting on the reporting services server.

Do reporting services connect to the analysis services as a another domain account?

I have searched and googled for a answer for about 6 hours now without luck, i'm getting a bit frustrated to get this working.

I think its only a configuration setting that i have missed, so all suggestions are welcome...

By : Webking


Answers
Are you logged on as KORSNET\TFMAN?

If the datasource set up for the report is set to use the credentials of the user then it will attempt to authenticate to the database as that user.

Does IE show the site as being part of the local intranet? If not go into security settings and add it.

Does that user actually have permissions to read the database?

It could be the "double-hop" problem where credentials can be carried and used once, but not again, however I think this is unlikely in this situation.

By : cjk


This video can help you solving your question :)
By: admin