This version of the rendering library is more recent than your version of Android Studio. Please update Android Studio [duplicate]

Question!

I have just created new project in android studio. I am new with this tool. The problem is, it is not displaying me my design, It giving me error that,

This version of the rendering library is more recent than your version of Android Studio. Please update Android Studio

I research on it, and by reading this question I do the same android studio rendering library1

But now, I am getting java compilation errors in MainActivity.java file.

enter image description here

enter image description here

Do I need to import any library ?



Answers
Even I faced the same problem. My problem was solved by changing my current android version to API 22 Android 5.1.1 This video helped me get through the error https://www.youtube.com/watch?v=49CF6uU38Wo



This video can help you solving your question :)
By: admin