Why does one .o file in my project has no Provisioning Profile?

Question!

Im trying to submit a version of my app and after building im seeing the following screen

enter image description here

My app has a valid provisioning profile except one .o file that is for some reason not included in it..

That has been the case for a while now, and i have managed to submit the app without it being a problem.

A couple of day ago, after submiting a new version, i recived an email from apple saying :

We have discovered one or more issues with your recent delivery for "xxx". To process your delivery, the following issues must be corrected:

Invalid Signature - Code object is not signed at all. The binary at path [xxx.app/FooterCoverflowCollectionViewLayout.o] contains an invalid signature. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose "Clean All" in Xcode, delete the "build" directory in the Finder, and rebuild your release target. For more information, please consult https://developer.apple.com/library/ios/documentation/Security/Conceptual/CodeSigningGuide/Introduction/Introduction.html

Once these issues have been corrected, you can then redeliver the >corrected binary.

Regards,

The App Store team

I've tried the steps they recommended with no luck. Can anyone have any idea how to solve the issue ?



Answers

I experienced this exact problem, and would like to share what happened.

The .m file for one of the classes we had written (ie: not a third party library) had been erroneously added to the project in the "Copy Bundle Resources" section in "Build Phases". There is no reason for the file to have been there, and had been there for quite a long time.

The error described in the original post just started showing up in our latest submission to the app store last week, and from what I gather from other posts around the internet, Apple has recently changed something about their code signing and submission process. The .m was absolutely in the Copy Bundle Resources section in our last several submissions.

Simply removing this file, rebuilding, and resubmitting solved the problem. Since the file didn't need to be there in the first place, there was no need to add it back again.

There may be other causes for this error, but if you get this error, check your "Copy Bundle Resources" section the files that are being listed with zero entitlements.



This video can help you solving your question :)
By: admin